Riders Of Vision

General => Board Archives => Topic started by: 200xRyder on September 20, 2002, 06:27:32 PM

Title: Found a Vision 2 days ago.... (82 I think)
Post by: 200xRyder on September 20, 2002, 06:27:32 PM
 ;D ;D

This thing was dirty as hel1...i had , had my eye on the machine since Tuesday so today I took a trip over to the owner's house (lives within 2-3 miles of me on a big farm) to see if he was interested in selling it. At 1st he said "ah...$500 Ill give it to ya"...I said hmmm..."Can I go check it out"...So we went down to the barn where it had been stored since 96...Its a complete bike....he hooked it up to his truck (battery wasnt in it..but wouldnt be any good after 5 years anyways probly)....and after about 8 trys and 10 minutes, the thing started right up....Nice quit(er) machine....shaft driven.

Also: The guys the original owner and has all the paperwork with a title.

Thanks all,
Rob

and heres one more pic from the net: This resemblers it but it -did have- dual exhaust unliek the one in the pic....thanks.

(http://66.60.165.141/nss/Pictures/vision1.jpg)
Title: Re: Found a Vision 2 days ago.... (82 I think)
Post by: 200xRyder on September 20, 2002, 06:30:39 PM
also: Problems are this:

Little rust
Needs carb cleaned form sitting for 6 years (still ran)
Needs a Battery (its gone)
Front brake kinda rubs (rust build up--another no biggie).

question: I noticed the machine has "linkage" shifter..had any problems with that yet?

Rob
Title: Re: Found a Vision 2 days ago.... (82 I think)
Post by: Lucky on September 20, 2002, 07:18:10 PM
Shifter linkages are one area i've never heard anyone mention having a problem with.
there are a couple of pages for new vision owners and 10 common vision problems on my website, Vision Resources. ?enjoy your new V!
--Lucky
http://www.geocities.com/lucky_142